Salesforce Unplanned Maintenance
Incident Report for Propel
Resolved
Salesforce has reported that most customers should be able to log in again. They have noted that customers using multi-factor authentication may still have troubles logging in. Please reach out to support@propelplm.com if you are still having issues logging in.
Posted May 11, 2021 - 18:53 PDT
Monitoring
Salesforce has shared the following update:

"The Technology team is confident that this incident was the result of an internal DNS change. We are starting to get reports that some customers are able to access their Salesforce services, and we continue to closely monitor that aspect of the recovery."

We are also seeing that customers are starting to be able to login again. We are still closely monitoring this situation. Please try logging in and reach out to support@propelplm.com if you are still running into errors.
Posted May 11, 2021 - 17:25 PDT
Update
Salesforce has shared the following update:

"The Salesforce team continues to isolate the root cause to mitigate the impact to other services."

Propel Support will share additional updates as we have them.
Posted May 11, 2021 - 16:57 PDT
Update
Salesforce has shared the following update:

"Salesforce is all hands on deck for this incident and exploring multiple paths to resolution. The root cause investigation also continues as the Technology teams are looking at the possibility of a block implemented by a third-party DNS provider, as well as any recent network changes."

Propel Support will share additional updates as we have them.
Posted May 11, 2021 - 16:29 PDT
Update
Salesforce is aware of the issue and provided the following update:

"The Salesforce Technology team became aware of an issue impacting multiple Salesforce services. Customers will experience isues while navigating multiple Salesforce services, including the Core application, Marketing Cloud, Commerce Cloud, and Experience Cloud (fka Communities).

The impact is also impacting the Salesforce Trust site, status.salesforce.com is not accessible.

Path to Resolution: The team is pursuing multiple paths to resolution and is actively investigating to determine the root cause."

Propel Support will continue to post updates as they are available.
Posted May 11, 2021 - 16:03 PDT
Update
We are continuing to investigate and are waiting to hear additional information from Salesforce regarding this outage.
Posted May 11, 2021 - 15:28 PDT
Update
We have identified that this is a global Salesforce service disruption. We are waiting for Salesforce to provide additional information.
Posted May 11, 2021 - 14:58 PDT
Update
We are continuing to investigate this issue.
Posted May 11, 2021 - 14:35 PDT
Investigating
It has come to our attention that users are unable to log into Salesforce and some are getting a "We are down for maintenance" message. This error is on Salesforce's end and we are currently investigating this issue.
Posted May 11, 2021 - 14:30 PDT
This incident affected: Propel Core Functionality, Propel Import, Propel Export, PDF Generation Service, Mobile App and Integrations (FDA Medwatch Integration, Solidworks Integration, Onshape Integration, AWS S3 Integration).